09/06/06 02:36:15
>>913
命名規約がなかったり無視されたりしがちな社内製作、社内利用の
アプリケーションなんかだと良くあるよね。
とりあえずRubyみたいにメンバ変数は"@"で始まるとか
文法で決めてしまってくれたほうがすっきりして良いと思うんだけど、
Java改良版(と個人的に思っている)のC#でも採用されないところをみると、
みんなあんまり好きじゃないのかな?
915:デフォルトの名無しさん
09/06/06 02:41:16
いっそのことJSやらPythonやらみたいにthis強制でいいと思う
916:デフォルトの名無しさん
09/06/06 04:45:29
DAOのメソッド名を考えています。
命名規約のようなものが見つからないので、
とりあえず自分では以下のように考えているのですが、
何か駄目出しがあったら教えて下さい。
find(一覧取得)とget(一行取得)の使い分けが
微妙かなーと思っているのですが...
count() - レコードの総件数を取得
countByFoo - 条件指定の件数取得
countByFooAndBar - 条件が複数ある場合の件数取得
countByCondition - 条件が多数ある場合の件数取得
findAll() - レコード全て取得
findByFoo - 条件指定の一覧取得
findByFooAndBar - 条件が複数ある場合の一覧取得
findByCondition - 条件が多数ある場合の一覧取得
getByFoo - 条件指定の一行取得
getByFooAndBar - 条件が複数ある場合の一行取得
getByCondition - 条件が多数ある場合の一行取得
insert - 追加
update - 全件更新
updateByFoo - 更新
delete - 全件削除
deleteByFoo - 条件指定の削除
917:デフォルトの名無しさん
09/06/06 07:07:58
「最後にHogeを○○した時刻」を示す変数は、どういう名前にしたら良さげかな?
○○には、実行、更新、取得などの動詞が入る予定。ちなみに保持する時刻の単位はミリ秒。
last_time_when_do_hoge?
last_time_when_did_hoge?
なんか長いよ…。
>908
言われてみれば、プリフィクス以外で、mhで始まる単語はパッとは思いつかない…気もする。
>914
Perlは前に付ける記号で意味が変わってくるからなあ。
@$hogeみたいに複数くっつく場合とか、もうね……。
918:デフォルトの名無しさん
09/06/06 07:48:14
一番要らないものを順に省いてってよさげなところでとめてみる
when
time
hoge
↓
last_XXXed
last_YYYed
919:デフォルトの名無しさん
09/06/06 08:03:43
XXXed_at
920:デフォルトの名無しさん
09/06/06 08:18:01
latest_XXed_msec
921:デフォルトの名無しさん
09/06/06 08:36:27
ありがとうございます。参考にしてやってみます。
>919さんの方法はちょっと目ウロコでした。
922:デフォルトの名無しさん
09/06/06 12:12:37
必要な語を全部入れなければいけないなら長くはなるだろうな。
time whenのかわりに最後にatを付けるなどして、
last hoge update at (最後にhogeを更新した時刻)などとしては?
923:デフォルトの名無しさん
09/06/06 12:14:37
りろー(ry
924:デフォルトの名無しさん
09/06/06 12:14:55
MS的にはLastWriteTime, LastAccessTime
925:デフォルトの名無しさん
09/06/06 12:59:24
どれくらいのスコープで使うの?
大きいスコープなら長めの変数名でいいと思うけど
926:デフォルトの名無しさん
09/06/06 18:33:34
>925
10行くらいの関数の中。ごめんなさい。
927:デフォルトの名無しさん
09/06/06 19:37:17
>>917
lastDoneTime
928:デフォルトの名無しさん
09/06/07 01:30:50
.NETでフォームアプリケーションを作っているのですが、
コンボボックスに日付を入れるようなメソッドのプレフィックスは何がいいでしょうか。
今はsetXXXXToComboBox1のようにsetを付けています。
addやappendはなんとなく違うような気がして。
また、引数でbool値を渡して、それによって動作が変わるような変数は
どのような名前が良いでしょうか。
動作自体を切り変えるような場合はshouldXXXX、
戻り値を切り変えるような場合はrequiredXXXXにしています。
929:デフォルトの名無しさん
09/06/07 01:46:19
shouldもrequiredも無くしてXXXXだけの方がいい
つか「戻り値を切り替える→required」てのが意味わからん
930:デフォルトの名無しさん
09/06/07 02:20:39
booleanを与えて動作自体を切り替えるがshouldていうのもわけわからん。
931:デフォルトの名無しさん
09/06/07 10:37:45
Addがいいよ。
bXxxxでええよ
932:デフォルトの名無しさん
09/06/07 11:10:59
>bool値を渡して、それによって動作が変わるような変数
引数の形式でどうやって命名するんだ。
機能を言ってくれんとなんともいえん。
933:デフォルトの名無しさん
09/06/07 11:13:33
cmd というプリフィクスも、ないことはない
934:デフォルトの名無しさん
09/06/07 11:16:35
ここは定石通りにhogehogeflagという方向でですね